Web Portal and API

Incident Report for Claim MD

Postmortem

Incident Date: May 13th, 2025
Timeframe: ~1pm – 4:23pm (Mountain)
Status: Resolved

What Happened

On May 13th, Claim.MD experienced a service outage that impacted access to our web portal and API, and caused delays in data processing through our SFTP system. Our engineering team quickly identified the issue and worked to restore full functionality as promptly as possible.

What Caused It

The outage was triggered by an internal process that was intentionally run in our production environment as part of routine validation and testing. While the process was expected to be non-disruptive, it had unintended side effects that affected service availability more broadly than anticipated.

What We Did to Fix It

Once identified, the underlying process was halted and affected systems were brought back online. Services were restored and closely monitored to ensure stability and performance returned to normal.

What We’re Doing to Prevent This Going Forward

We’re taking the following steps to ensure this type of issue does not occur again:

  • Updating internal workflows to better separate testing activities from live systems.
  • Adding additional safeguards to minimize potential service impact
  • Enhancing monitoring and alerting for faster detection and response.

Our Commitment

We know how much our services matter to your business, and we sincerely apologize for the disruption this incident caused. We’re committed to learning from this event and making the necessary changes to improve our reliability moving forward.

Thank you for your patience and trust in Claim.MD.

Posted May 13, 2025 - 19:35 MDT

Resolved

The recent service outage has been resolved.

We identified that an internal testing process unintentionally triggered a widespread disruption. We’re updating our workflows to prevent this type of issue from occurring again.

We apologize for the inconvenience and appreciate your patience while we worked to restore services.
Posted May 13, 2025 - 16:28 MDT

Update

We’re currently addressing a service disruption that began earlier today. While resolution may take a few hours, we can confirm this is not a security-related incident.

For ongoing updates, please visit https://status.claim.md.

We appreciate your patience and understanding.
Posted May 13, 2025 - 15:06 MDT

Identified

We've identified the associated problem and are working to resolve it.
Posted May 13, 2025 - 14:03 MDT

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 13:18 MDT

Investigating

We are currently investigating an issue that is affecting our Web Portal and API access.
Posted May 13, 2025 - 13:18 MDT
This incident affected: Web Portal and API.