Web Portal Login Issues

Incident Report for Claim MD

Resolved

This issue has been resolved, users should now be able to log in to the web portal normally.
Posted Mar 04, 2026 - 15:29 MST

Investigating

We are aware of an issue affecting web portal logins and are currently investigating.
Posted Mar 04, 2026 - 15:17 MST
This incident affected: Web Portal.