Phone System Outage - AWS

Incident Report for Claim MD

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 17:01 MDT

Identified

The issue has been identified and our provider is working to resolve the issue.
Posted Oct 20, 2025 - 08:08 MDT

Investigating

Notice of Service Interruption

We are currently experiencing intermittent issues with our phone system due to a widespread outage affecting our cloud service provider.

In the meantime:
- For support inquiries, please login to the web portal to create a ticket.
- For sales inquiries, please schedule a demo from www.claim.md.

We appreciate your patience and understanding as our provider works to resolve the issue.
Posted Oct 20, 2025 - 08:08 MDT
This incident affected: Phone System.